Wednesday, August 26, 2015

IE users must upgrade to use Scopus

Do you like using the Scopus citation index and guide to scholarly literature?

Great!

Now, if you use Internet Explorer, you'll need to be using a more recent version than IE 8.

Here's the announcement that was sent to our electronic resources librarian:

Dear Customer,
As a designated administrator for Scopus, we wanted to remind you that effective October 1, 2015, Scopus will no longer support Internet Explorer 8 (IE8).

Why are we ceasing support of IE8?

We are following Microsoft’s directive to focus our support on newer, officially-supported IE browser versions. Microsoft announced in 2014 it would only support the most recent IE browser version with technical support and security updates. We strongly encourage our customers to also follow Microsoft’s directive by updating to more recent versions of IE or by using other supported browsers.
We will discontinue support a few months ahead of Microsoft’s official deadline of January 2016 in order to get an earlier start on some major projects. By removing IE8 from our support list, we will be able to provide the following future enhancements:
  • Remove current IE8 security issues
  • Enhance existing security measures across all browsers
  • Add support for new browser technologies
  • Add responsive design to aid use of Scopus across devices
  • Improve accessibility to better enable access to people with diverse abilities
If you have any questions or concerns, please contact us:
usinfo@elsevier.com – US & Canada
nlinfo@elsevier.com - Europe
sginfo@elsevier.com – Asia, Australia & New Zealand
brinfo@elsevier.com – Mexico, Central & South America
Best regards,
The Scopus Team